Access sandbox via ssh


I would really like to access a sandbox over ssh, not only over the web console, but I can not get a connection to work.

I always get

ssh_exchange_identification: Connection closed by remote host

Either when setting the port to 22 and not running anything else or when using this this to multiplex it with my webserver on port 80.

I assume that either buddy is blocking SSH connections, or it does not work with the way the domain and/or the IP are set up for sharing / load balancing.

Has anyone done this? Or is it intentionally blocked?


Hey Karl,
It’s not possible to access the sandbox over ssh yet, except for the terminal in the application. We’re going to add an option that will let you define additional ports for ssh access in the future. It’s still too early for the ETA, though.


That’s great. Good enough for me without an ETA. I don’t need the feature for anything critical. It would be a neat option to use sandboxes as dev environments from platforms where they can’t run natively (specifically iOS with the SSH Upload feature of the Working Copy app).