Buddy Enterprise - Don't find Pipelines option


#1

I’ve installed Buddy Enterprise on my Mac and was able to create a project, connect it to my GitLab and select a remote repository.

In the top blue bar in the middle, I see only “Code” but not “Pipelines”.

Screenshot: http://d.pr/i/70v0Bi

Any idea?


#2

@srikat, this has been solved via chat in-app.

If your repository is empty you wouldn’t see the Pipelines tab at all.


#3

Thanks for your reply.

I pushed a commit to the repo on GitLab, waited for more than 10 min but Buddy still says

Push some code…
gitlab.com/srikat/project is empty

https://buddy.works/knowledge/standalone/integration-gitlab-self-hosted says

IMPORTANT: make sure that external_url is properly set in your /etc/gitlab/gitlab.rb config file or the integration will not work.

Do you mind telling me where I can view/edit that file?

I tried running

sudo docker exec -it gitlab vi /etc/gitlab/gitlab.rb

but get

Error: No such container: gitlab


#4

I’m pasting the same response you received on Intercom:

The file should be in the path: /etc/gitlab/gitlab.rb, but most probably it’s not about the configuration of GitLab standalone.
_From what I can see, you have the address on which Buddy is installed: 10.0.0.1 _

_Do you have it installed on Azure? Such IP is not visible from the outside, so no webhooks will be received. _
Make sure to try this one: https://buddy.works/knowledge/standalone/installation-azure#update-ip-address-of-buddy-enterprise