Buddy Go Installation problem "Starting application failed"

Hi Dear

I follow this guide https://buddy.works/knowledge/standalone/installation-linux for installation on my dedicated server iwth ubuntu 14.04

But when is installing i get this error:

“Starting application failed”

SSH Log:
Application is starting…
It can take a few minutes
Pulling utility-update (buddy/utility-update:1.0.41)…
Pulling mongo (buddy/mongo:1.0.41)…
Pulling redis (buddy/redis:1.0.41)…
Pulling mysql (buddy/mysql:1.0.41)…
Pulling updater (buddy/updater:1.0.41)…
Pulling git-server (buddy/git-server:1.0.41)…
Pulling front (buddy/front:1.0.41)…
Pulling build-server (buddy/build-server:1.0.41)…
Pulling application-server (buddy/application-server:1.0.41)…
Pulling haproxy (buddy/haproxy:1.0.41)…
Pulling utility (buddy/utility:1.0.41)…
Creating network “buddy_default” with the default driver
Creating buddy_utility
Creating buddy_sql_db
Creating buddy_build_server
Creating buddy_session_store
Creating buddy_nosql_db
Creating buddy_front
Creating buddy_git_server
Creating buddy_application_server
Creating buddy_proxy_server
Starting application failed
Stopping buddy_proxy_server … done
Stopping buddy_application_server … done
Stopping buddy_git_server … done
Stopping buddy_nosql_db … done
Stopping buddy_session_store … done
Stopping buddy_build_server … done
Stopping buddy_sql_db … done
Stopping buddy_utility … done
Removing buddy_proxy_server …
Removing buddy_proxy_server … done
Removing buddy_application_server … done
Removing buddy_git_server … done
Removing buddy_front … done
Removing buddy_nosql_db … done
Removing buddy_session_store … done
Removing buddy_build_server … done
Removing buddy_sql_db … done
Removing buddy_utility … done
Removing network buddy_default
Installation aborted

I send “buddy feedback” command…

How i can fix this? where i can find installation log?

Thanks!

Hey @LectorRSS

Seems like one of the containers stopped at the installation process. Have you tried to install it once again?
If the problem still occurs, we’d need to connect to your machine to investigate it.

@LectorRSS Where you able to solve that issue? Is this regarding docker network issues?

@MobileAppVault i never fix it… i only need git to ftp.

Buddy Go never work for me ( i try install how much times)

Now i use “GitFTP” https://github.com/git-ftp/git-ftp

1 Like

@LectorRSS got the information this issue will be fixed in the new release next week. :slight_smile:

Hi,

i was able to fix this issue to setup the right DNS nameserver in my network settings :smiley:

nano /etc/network/interfaces*

# This file describes the network interfaces available on your system
# and how to activate them. For more information, see interfaces(5).

source /etc/network/interfaces.d/*

# The loopback network interface

auto lo
iface lo inet loopback

# The primary network interface
auto ens3
iface ens3 inet static
        address X.X.X.X
        netmask 255.255.252.0
        broadcast X.X.X.X
        gateway X.X.X.X
        dns-nameservers 8.8.8.8 8.8.4.4
1 Like

Javier [@LectorRSS]
The issue has been fixed in the last released. I strongly recommend to give Buddy another shot: it’s a much more reliable and scalable solution in the long-term.

Marcus [@MobileAppVault]
Glad to hear it’s working! You can reset the settings to default if you wish, though :slight_smile:

still not working for me.

edit:
tryed it 2 more times and now it worked, very strang

Same trouble here, first it got disk full, then I tried to restart and couldn’t and then I tried to resinstall and I couldn’t reinstall my version, had to install again your version and crashed.

VERY VERY BAD, this destroyed my last 20 days of work in row

Alejandro,

We’re sorry to hear that. In general, we recommend contacting the support team prior to taking action on your own since every use case is different. We usually solve it by inspecting the feedback from the buddy --feedback command and/or opening an ssh tunnel and fixing the issue directly on the client’s machine.

There’s also a specific course of action in case of running out of space during the update: https://buddy.works/knowledge/standalone/standalone-update#failed

We’re aware it’s too late now—this is rather a note for other users in case they’ve run into a similar situation and are seeking for help here.