Buddy is out of Synchronization with my Bitbucket repository?

Hi everyone,
I am posting because I want to fix the this problem as soon as possible. I have simple pipeline line that await for pushes from a repository in my Bitbucket and push them to an ftp server. It was working fine till today, I did some pushes but Buddy keeps showing me the old revision? Is there any problem with buddy at the moment?
You can see here the difference:


and even running the pipe manually everything still the same :

Hi @mohessaid,

Make sure to contact us at: support@buddy.works
Attach both the link to your account and to the project you’re having problems with. We’ll investigate it carefully.

I am having the exact same issue on my Buddy Go installation that we’re testing for our company. What solution you guys got to for this?

The webhook URL within my Bitbucket repo is not responding correctly. When I tried to do a post request on that url here’s what I got:

@faisal have you followed the instructions from here: https://buddy.works/knowledge/standalone/integration-bitbucket ?

The most important part is:

Set up the Webhook address. The webhook is an URL to which Bitbucket will send information on changes in the repositories. The address must be available from the outside: if your installation is assigned to an internal IP (eg. 192.168.x.x), make sure to paste your external IP to that field and redirect the oncoming traffic on your router to the address of your Buddy GO instance.

Most of the problems are caused by the network configured in a wrong way and the connection between Bitbucket and Buddy’s machine is not working properly as well as a result.

Yes, the url is easily accessible and its public. If you show the error I given in above screenshot to developers they might able to better guide us about it.

@faisal, we’re not able to debug this issue without direct access to your machine. Could you give us access via ssh?

@Octavia Yeah, sure why not. How I can send you the credentials?

Nevermind, just posted a message using https://buddy.works/contact

thanks, we received it. I’ll keep you updated

Edit your webhook and see if “Skip certificate verification” is enabled. It works for me again.