Bypassing Low Memory Prompt on Startup

Hello,

I have a 2GB VM that doesn’t expose all 2GB of memory (but close) to Buddy. Therefore on starting Buddy up, I am always prompted for the Yes/No to continue, since the memory is low.

Is there any way to set a config value or check to bypass this prompt and always start? Any system restart will set Buddy’s status as starting indefinitely until I stop and then start it again interactively.

I absolutely love the product, it has made my life infinitely easier. Thank you very much!

-Adam

@alistek, we’ve already added such option, just update your CLI.

PS. We’re happy to hear you love Buddy! :slight_smile:

Wonderful! I just updated and tested it and it works great.

One other CLI related question then, is there a way to do an automated backup that keeps the prior backups? I was working to script all of that and bypass those prompts.

Thanks!

-Adam

Cool! As for your question: try to write a script like that:

buddy stop
buddy backup -y
buddy start

Ah, that makes sense. Thank you very much!

-Adam

you’re welcome, @alistek!