Callback url is 404?

Hey guys,

Running Buddy go on Digital ocean droplet. It used to work great with gitlab.com integration.

This morning we did two things:

  1. Upgraded Buddy Go to latest version
  2. Added integration for gitlab ce, and dropping integration for gitlab.com

I can manually run a pipeline, and it goes through without issues, but it simply refuses to auto-run. If I go into that pipeline and look at the execution details it tells me that it executed a revision from yesterday. It won’t pick up ANY revisions beyond that.

It looks like somehow gitlab ce and buddy isn’t talking, but everything is set up correctly. If I try to visit the callback url I get a 404 error.

Any idea what I could be missing?

Hi Adrian,

The revision is not available because GitLab is not synchronizing correctly with Buddy. This is a very difficult issue to debug from our side as it would require giving us access to your machine, GitLab account and perhaps network settings. There are two things, however, that you can check:

  1. Buddy GO will only work with GitLab in v8.12 and newer. What’s your GL version?
  2. Make sure that external_url is properly set in your /etc/gitlab/gitlab.rb config file or the integration will not work.

You could try removing and re-adding the integration as well. We’ve had some trouble with GL in the past few weeks, this as well can be temporary. Can’t help you more I’m afraid.

Thanks I suspected as much. Thought I’d give it a shot nonetheless.

Thanks for the tips, will try them out.

Our gitlab is the very latest one, updated that yesterday too.

@traaidmark, just to let you know that it’s been fixed already

1 Like

Thanks a lot! Will run an update asap!