Error in sending license validate request on VirtualBox

I’m trying to set up Meat! in VirtualBox, but on the licence sending step it fails with a message “Error in sending license validate request.”

I’m guessing it’s because of network issues, but it’s not possible to debug it in any way.

I’ve tried various network configurations:

  1. Only one adapter with bridged network.
    This doesn’t work in VirtualBox. DHCP fails and even if static address is set there is no way to access the IP from the host system

  2. Two adapters: bridged network and host-only adapter.
    Meat! manages to set it’s network up for me and provides a “start here” address: http://192.168.56.101:8080
    Licence upload still fails

  3. Two adapters NAT and host-only adapter.
    This setup is what I’m using for all my other VirtualBox instances without issues.
    Start here address is yet again http://192.168.56.101:8080 but uploading licence fails again.

I’ve also tried to set up static network, but this only affects the connection between my host and vm. Eg using settings:

IP: 192.168.56.102
Subnet: 255.255.255.0
Gateway: 192.168.56.1
DNS1: 8.8.8.8
DNS2: 8.8.4.4

… gives me access from host to 192.168.56.102:8080 but yet again no external network for vm itself and licence upload fails.

Any ideas?

I’ve got the same issue.
Probably the file is being uploaded but something prevents it from being validated. While uploading file at the top of the website there’s a some kind of a blue progress bar. At the approx. 90% it starts blinking and then the error message appears. Any idea how to solve it?

@Edit:
The progress bar only appears in Chrome. In IE the error appears immediately after selecting file to upload.

Totally the same here. Anyone here to help us, or we should wait Odin to solve this?:slight_smile:

Sorry to have kept you waiting so long for the answer, guys. It’s really hard to tell what’s wrong at your side since we don’t have access to your machines. We’re working on some kind of solution that will allow you to debug such issues yourselves, stay tuned.

We have the same issue here. Is there anything we can do to make the machine run? Change the HostOS, Network-connection, pray to Odin as suggested?

What shall we do? (With the broken meat!?)

Regards Michael

Allright guys, I got it working on my own.
I booted the machine and switched in the Network module (Press N) to IPv6, DHCP. Afterwards I rebooted the machine and it came up without any Problems. (Still reachable with its IPv4.)

Now the Upload of the Licence Key works fine.
Good Luck everybody.

Regards Michael

Thanks your suggestion, sadly, it didn’t make it work for me :confused: