Gitlab CE, any [new] changes doesn't arrive Buddy


#1

I’m using the free Enterprise version of Buddy. It did its work correctly until yesterday.
I don’t know how but the Internal server killed all docker containers included Gitlab EE and Buddy. When I start the containers again, I realize, that buddy and Gitlab don’t work anymore synchronously. Buddy has the repositories and commits until the server killed them and every new commit doesn’t come in.

I tried to add Gitlab CE again in Preferences -> Applications -> Gitlab CE /EE but it doesn’t work. I tried almost everything.

Has anyone faced the same problem or has an idea what should not working?
Best,
Kemal


#2

@Ali_Kemal_Ozkan, try clicking Refresh (you’ll find it on the right in the Code tab). Also, take a look here: .buddy/app/data/backend/logs/application-server/webservice.log

Since it’s the free version that is not developed, we cannot recommend anything else.


#3

Hey Octavia,
thank you for the hint.
I found the problem, but I have no clue how to solve it.
The response from Gitlab API is 401 “unauthorized.” Buddy cannot access to Gitlab API.
I follow every step in the installation guide, isn’t the created Application (in Gitlab) for the authorization responsible?


#4

Ali, go to My-ID (click your avatar) -> Integrations -> List of active&available, and click ‘Add’ once again next to the integration with GitLab.


#5

Thank you, it solved the problem. But what is the solution for Projects which are added by old co-workers? Is there a way to authenticate the Projects again.?


#6

Hey Ali,
Sorry to keep you waiting for the answer. At the moment we can switch the repositories to another user’s integration – drop a word to support@buddy.works with the details if you want to do that. FYI we’re working on a feature that will let users manually switch repos, soon you’ll be able to do it yourself.