Installation Assistance: Install fails > Ubuntu 16.04 running on WMWare ESXi 5.1.0

Good day!

I humbly ask for some assistance, as a first time Buddy Go user, and with limited Docker Experience.

The Problem: Installation aborts while finishing up buddy_proxy_server item, then cancels the entire installation, see screenshot:

Hardware Specifics:
Remote datacentre hardware, running VMWare ESXi 5.1.0, Build 1065491
Installing OS: Ubuntu 16.04 (64-bit) Server

I followed the following install guide:

I’ve checked for major issues in the dmesg log, but the worst i can see is as similar to these:
[67404.040199] aufs au_opts_verify:1597:dockerd[6226]: dirperm1 breaks the protection by the permission bits on the lower branch
[67411.433971] device veth0b9b966 entered promiscuous mode
[67411.434072] IPv6: ADDRCONF(NETDEV_UP): veth0b9b966: link is not ready
[67411.437377] device veth36f9c2f entered promiscuous mode
[67411.437448] IPv6: ADDRCONF(NETDEV_UP): veth36f9c2f: link is not ready
[67411.437455] br-f1d3c5a1bedf: port 3(veth36f9c2f) entered forwarding state
[67411.437462] br-f1d3c5a1bedf: port 3(veth36f9c2f) entered forwarding state

My current thinking is revolving around that something with the virtual NIC emulator is not working according to plan due to the hypervisor maybe being out of date, and thus causing Buddy Go Application installation to fail when it attempts the proxy installation. Not sure if that is even relevant to think?

Is there perhaps a debug parameter, or verbose mode to use (apologies for my noobness)?

Any assistance will be appreciated!

Regards,
Herman

Hi @monkigland,

Please run buddy feedback in your console - it’ll send us your logs so that we could investigate it carefully

@monkigland where you able to fix that issue?

same error but with Ubuntu 16.04 in Hyper-V

edit:
tryed it 2 more times and now it worked, very strang

@MobileAppVault We opted to go for a Digital Ocean droplet with 4GB+ memory, and its working like a charm so far. I think there might be hidden architecture incompatibality that is of rather obscure nature - which might require inordinate amount of time and effort to figure out when the simple answer is: use more modern hypervisor / virtual platform / architecture.

Thanks for the feedback and apologies on delay!

@Frankstar Yeah - very strange, but thanks for reporting that… glad it’s working though! And again, thanks for sharing!

1 Like