Installer does not work on CentOS 7


#1

Following the instruction from the How to install Buddy Enterprise on Linux server when you reach the following line

curl -sSL https://get.buddy.works | sh && sudo buddy install

on CentOS 7 (CentOS Linux release 7.4.1708 (Core)) you would get an error message that “buddy” command not found.
Moving

/usr/local/bin/buddy

to

/usr/bin/buddy

solve the issue.


#2

The other solution is to simply run the command line “sudo buddy install” (instead of sh && sudo buddy install)
I reported this error to the dev team and they took 3 days to just say “It works fine for us”…Sad


#3

Hello @artworked,

Your approach would not work for my case.

Before posting this issue I manually put content of https://get.buddy.works to bash script, executed it and only then run buddy install (everything from root)
Yet it didn’t work either because buddy wasn’t in the path.

Try to google centos /usr/local/bin/ and you’ll find out that it’s a common issue that commands from /usr/local/bin/ can’t be found.

Thanks for the reply.

With best regards,
Dmitry


#4

Guys, thanks for your posts. We’ll correct things on our guides for sure, thanks for pointing it out.

@artworked: sorry for the bad impression you had while contacting our support. That’s not what we meant. The thing is that we checked the entire guide paying special attention to CentOS (new DigitalOcean droplet) and everything worked perfectly on our side.
Basing on that, we assumed that the problem is with the client’s host. Unfortunately, such problems are hard to debug and it takes a lot of time.That’s why we limit support for free accounts to forum help only. Paid accounts have additional, dedicated support.

We’d like to help all users to configure things on their side, however, we’re not able to do that phisically.

Once again, thank you for pointing out things that should be improved in our guides.


#5

Using Centos 7 with a minimal install? Doubt that…

To clarify… the following commands would work on Centos 7.x

curl -sSL https://get.buddy.works

Then

buddy install

100% and without moving/modifying anything.


#6

Hello @artworked,

here is the exact list of commands I tried to use once the one from guide haven’t executed:

curl -sSL https://get.buddy.works > installer
chmod +x installer
./installer
buddy install

and I got the same error that buddy not found.

With best regards,
Dmitry


#7

Thanks a lot Guys once again for these comments. We’ll check things with “Centos 7 with a minimal install” again and correct our guides accordingly.

Have a nice day!