Kubernetes "set image" failing


#1

Hi

I’m trying to set up a pipeline in order to build a new docker image and deploy it to our cluster (sitting on Azure AKS). Unfortunately the pipeline is failing on the “Set image in K8s deployment” action with the slightly-vague error message: “Something went wrong.”

Just wondering if anyone else has had the same issue, or might have some insights into how best to trouble shoot etc.

Authentication to the cluster is working (using a token), as it allows me to see and select the correct Namespace, Deployment and Container.

Any help appreciated!

Thanks

  • Tim.

#2

Hi Tim,

You’re on the standalone version, right?
Make sure to run this action again with clear cache. If it fails, run buddy feedback from your terminal straightaway.


#3

Hi Octavia

Thanks for the response. Yes, we’re on standalone version. Will give that a try.

Kind regards

  • Tim.

#4

Ah - actually the issue, just to clarify, is when creating the action - and it doesn’t let me complete / save, so I can’t get to a point where I can then run the pipeline to trigger the action. So not sure if that helps - attaching a screenshot:


#5

Got it, Tim. Could you run buddy --tunnel from your terminal?
We’ll investigate that.


#6

Sure thing! Tunnel is running now (and have put into a screen session to keep it up


#7

Tim, one small detail I missed: could you please open the tunnel between 7 a.m - 3 .pm CET so that our devs could take a look?

Thanks!


#8

Hi

That should be up and running - will leave it running indefinitely

Thanks!

  • Tim.

#9

Tim, could you try running buddy --tunnel again? We haven’t received anything :wink:


#10

Hi Octavia

Hmmm - had that running in a screen session… is it something that needs to be restarted periodically? I’ve tried again and it seems to be up and running. Sorry it’s proving tricky!

Thanks

  • Tim.

#11

It should start working properly once you restart your standalone


#12

Restarted and run as root - hopefully that works now!