.Net projects + nUnit


#1

This probably isn’t a problem, but me missing on some configuration or specific setting, but today I set up my first .Net build successfully, and wanted to extend that, so I was trying add the automated unit tests run on Buddy, since I’m using nunit.

I first tried doing apt-get for the nunit-console component, but in the end couldn’t so I ended up adding a second step for a ubuntu desktop and pulling this docker image: https://hub.docker.com/r/itsverywindy/nunit-console/

After some attempts, I had an issue which is the following:

Anyway, I think that at least one more person apart from me should have this issue in the past (I.E: Running NUnit tests on Buddy) so, if any of the readers can help me out, it’d be great! If not, well, i’ll keep trying some things, but just letting you know about the issue. Thanks again!


#2

Hey @Zeroark,
Sorry to keep you hanging for the answer. We’ve had a look at your logs — the image that you used had a wrong tag. You should go back to this action, click the tag and choose it once again.


#3

Hi Kivlov
Is there a tutorial or more detailed explanation for running NUnit-Test from a Mono-Project.
Unfortunately i haven’t found anything… The build process runs smoothly on an Ubuntu-Image,
but as i said, any try to run an automatic test within the solution fails. And really, i have tried
many different possibilities.
Cheers and thanks in advance, Kay


#4

@responsiveKaysta

Unfortunately we don’t have such guide available.
Could you let us know how you configured it for now? Based on a particular example we’d see what can be done about it.

In general, NUnit needs to be installed to test .NET from the command line.
Make sure to add the following to the Packages tab: apt-get install nunit-console

The test itself should be done this way: nunit-console Test/bin/Release/MyTests.dll