Running in random erros using chrome pupeteer docker/node container


#1

Hey there, we have been running into build errors using critical css/penthouse tasks that rely on pupeteer, it does all work local but on buddy we do get errors like:

Unhandled Rejection at: Promise { <rejected> Error: Protocol error (Runtime.evaluate): Session closed. Most likely the page has been closed. at Session.send (***/node_modules/puppeteer/lib/Connection.js:167:29) at ExecutionContext.evaluateHandle (***/node_modules/puppeteer/lib/ExecutionContext.js:52:77) at ExecutionContext.evaluate (***/node_modules/puppeteer/lib/ExecutionContext.js:37:31) at Frame.evaluate (***/node_modules/puppeteer/lib/FrameManager.js:211:26) at Page.evaluate (***/node_modules/puppeteer/lib/Page.js:582:43) at ***/node_modules/penthouse/lib/core.js:146:18 at <anonymous> }

After researching and trying to install different packages we figured out that it is linked to this issue:


https://github.com/pocketjoso/penthouse/issues/220 (at the bottom)

How is it possible to change the the allocated RAM, is it possible to change it when initializing the docker image on the first execution ?

thanks a lot for all your awesome work :slight_smile:


#2

I managed to use an own dockfile, however that doesn’t help since i cant increase the shm-size to 1gb :frowning:


#3

@hendrikeng, unfortunately it’s not possible to change the shm-size. You can only increase RAM for the entire build. The amount of RAM assigned depends on the plan you have chosen. There are 3GB of RAM for each build on the trial version.


#4

@Octavia thanks for the reply, thats what i figured. we are on enterprise, would it be possible to check the pipeine what exactly is causing the error. my research was mainly based on assumptions. thanks for all :slight_smile:


#5

you can always browse the execution’s logs to find any details, however, it’ll be hard to find more info on this error.

Also, if you’re on the standalone, you can increase the limit for builds yourself:

  • run sudo buddy configure
  • choose the 9th option: Set build memory limit

#6

@Octavia thanks, tried it, didnt help changing it back resulted in a Application didn't start properlyno matter how often i restart, with the default settings


#7

I see, please run buddy feedback from your terminal - we’ll investigate it


#8

@Octavia thanks a lot , much appreciated