Self-Hosted Meat external access

I have a self-hosted meat instance running but I cannot access it outside of the network; So far it only works if I access it across the LAN. I have a static external and internal IP address and have assigned it to a DMZ to ensure that there are no firewall rules blocking access but I still cannot get it to work.

Any ideas as to why I cannot access meat?

My current thought is that Meat is listening on the internal address (192.168.254.X) instead of 0.0.0.0 so it’ll only respond to connections by LAN. Is there a way to change this?

It looks like you’ve got your network adapter in the VM set to NAT mode instead of Bridge and DHCP doesn’t assign IP’s properly. Could you check on that?

Currently there is no option for htat. but the VM is currently on a static IP address on the network and seems to talk fine with every other computer on the network; if I VPN into the network it works too but stops as soon as I access it from an external IP.

It looks like you’re using VMWare on Windows. I ran into the same issue but on Mac. I set my Network connection to share from Mac and then I had to do a little bit of port forwarding via a VMWare configuration file. This is the how-to I found:

http ://apple.stackexchange.com/questions/80266/nat-port-forwarding-from-host-to-client-in-vmware-fusion-5

I would assume there is similar for Windows. You’ll have to fix the link above since for whatever reason this message board thinks that my one link is actually 2+ :grin:

It’s not VMWare in Windows sorry, that screen shot is just the interface for changing settings.

The VM is running on a HP box ESXi; it’s a huge box running loads of virtual machines for customers. It has its own network adapter that isn’t bridged, or nat’d, it runs like a physical machine. It has its own static internal IP purely for this individual VM.

If those VMs can reach the outside world there must be some sort of NAT device on the network. You’re going to likely need to access that device or the router to do some sort of port forwarding from your external/public address to the internal address for the VM where Meat is.

it was given a dedicated static external IP; but it still won’t respond to requests. Even if I open every single port, it still won’t respond to external requests

Thanks for everyones time, I got it working by rebooting the entire network, restarted the router, the switch, and the VMWare controller.

I guess there was a config somewhere not updating, or packets being transferred incorrectly.

Either way, thanks for the help everyone :smile:

/close topic/

@Duffleman Glad you got it working! :+1:

Hi Duffleman, I have the same problem. When I enable the DMZ to the MEAT! everything is OK, but I use the DMZ for my ESXi server at home. So I can’t keep it only for MEAT… When I open the 443 port, only login page and dashboard loads. If I try to click somewhere everything blocks and says “There are no webpage” or something like that. Can you tell me the ports of MEAT? Thanks!

Open ports

80
443
8080
8443
22
1983

1 Like